Results 1 to 11 of 11

Thread: Building an LED light for my 55g

  1. #1
    DIYFK member Zman3k's Avatar


    Join Date
    Oct 2015
    Location
    San Jose,ca
    Posts
    17
    Post Thanks / Like

    Building an LED light for my 55g

    I've been wanting to do a DIY LED fixture for my tank for long time, and now that I've got my 55g up and running the light is pretty lacking for the plants that are in the tank. I am a sheet metal worker by trade so I made the housing myself.

    Light_Housing_50.jpgLight_Housing_MockUp_50.jpg

    It will have 30 LEDs total a 50/50 mix of 6500K and 10,000K whites, and 10 Royal Blues(I'll be wiring in a switch to have either all on or only RB on). I may have gone a bit overboard with the heat sinks but I wanted room for upgrades later on should I ever want to add more lights. It will be actively cooled with 12v computer fans, I will be powering those with buck converters (they'll be wired into the RB channel so they come on no matter what LEDs are running.)

    Heat_Sink_Edge_1_50.jpg

    Im powering the light with Maxwellen dimmable drivers and will be able to control whites and PB's independently. I have everything ordered and am waiting for everything to come in so I can put it all together. I will post pictures as I begin building it and post pics of part numbers incase anyone is interested or is building their own and would like to copy parts of my build. Here's a pic of the tank currently with the light I will be replacing I'll edit with a before/after pic after the light is complete as well.

    Fish_tank_50.jpg

  2. #2
    DIYFK member Zman3k's Avatar


    Join Date
    Oct 2015
    Location
    San Jose,ca
    Posts
    17
    Post Thanks / Like
    I have no idea why my pictures are upside down, Can a mod help me out please??

    -ZMan

  3. #3
    DIYFK member HillbillyHomer's Avatar


    Join Date
    Sep 2012
    Location
    mo
    Posts
    2,472
    Post Thanks / Like
    Click here to enlargeClick here to enlarge

  4. #4
    DIYFK member Meep's Avatar


    Join Date
    Oct 2013
    Location
    Planet Earth
    Posts
    3,234
    Post Thanks / Like
    Click here to enlarge Originally Posted by Zman3k Click here to enlarge
    I have no idea why my pictures are upside down, Can a mod help me out please??

    -ZMan
    It's because of bad metadata in the image file, some graphics editing programs and even some cameras don't put the proper up/down metadata in the image...

    If you are on Windows, download this free and simple to use image editor, rotate and resave the images it will fix the orientation metadata then re-upload... I know for a fact this program will correct the orientation metadata...

    http://www.irfanview.com

  5. #5
    DIYFK member vanish's Avatar


    Join Date
    Mar 2014
    Location
    Longmont, CO
    Posts
    668
    Post Thanks / Like
    Housing is looking nice!

    As an aside, your current light looks an awful lot like the 48in Beamswork I have on my 75G. That's been more than enough light to grow my plants. However, Beamswork make so many different lights its hard to know for sure.

  6. #6
    DIYFK member Zman3k's Avatar


    Join Date
    Oct 2015
    Location
    San Jose,ca
    Posts
    17
    Post Thanks / Like
    Click here to enlarge Originally Posted by vanish Click here to enlarge
    Housing is looking nice!

    As an aside, your current light looks an awful lot like the 48in Beamswork I have on my 75G. That's been more than enough light to grow my plants. However, Beamswork make so many different lights its hard to know for sure.
    Youre right. Itís the cheapest beamsworks light off of Amazon. And while the java fern on top of the rocks is growing decently the anubias nana specifically has melted completely and I have 1 tiny leaf that hasnít grown at all in a month. I want to be able to grow other plants too in pots with aqua soil in them, for ease of cleaning I want to keep the tile bottom. That and I always love a good DIY project as Iím sure you can tell by the stand and sump in the pic
    -ZMan

  7. #7
    DIYFK member Zman3k's Avatar


    Join Date
    Oct 2015
    Location
    San Jose,ca
    Posts
    17
    Post Thanks / Like
    For those looking for an update I got the LEDs and lenses in last night however there was a mixup and I got sent the some extra whites instead of royal blues. Not a big deal though because they don’t even want the extra whites back. Just have to wait another week to get them.

    I do do have a question though about mounting the lenses. How am I supposed to do it? Will 3M mounting tape work? The lenses are about the same size as the stars that the LEDs are on so I dont have much to mount to. Just wondering how others have done it before

    -ZMan

  8. #8
    DIYFK member HillbillyHomer's Avatar


    Join Date
    Sep 2012
    Location
    mo
    Posts
    2,472
    Post Thanks / Like
    i have had luck using hi temp hot glue.
    led g.jpg

  9. #9
    DIYFK member Zman3k's Avatar


    Join Date
    Oct 2015
    Location
    San Jose,ca
    Posts
    17
    Post Thanks / Like
    Got the rest of my LEDs in yesterday and got them all mounted today. I used a thermal epoxy instead of arctic silver, the reviews said this was better, but who really knows?... I will say that I like not having to drill and tap two holes for every LED on my heatsink. Anyways here's a couple of pics

    mounted_leds_25.jpgthermal_epoxy_25.jpg

  10. #10
    DIYFK member Meep's Avatar


    Join Date
    Oct 2013
    Location
    Planet Earth
    Posts
    3,234
    Post Thanks / Like
    I will say that I like not having to drill and tap two holes for every LED on my heatsink.
    Personally, I would still do that (albeit I would probably use self-tapping screws, so I only had to drill a pilot hole) as I would not trust the epoxy to hold to the aluminum over repeated thermal expansion and contraction cycles...

    Another option is drill and pop-rivet or nylon spring rivet...

    If you decide to go with screws, I generally get my small hardware from https://www.microfasteners.com

  11. #11
    DIYFK member Zman3k's Avatar


    Join Date
    Oct 2015
    Location
    San Jose,ca
    Posts
    17
    Post Thanks / Like
    Thanks for the idea Meep!
    Last edited by Zman3k; 02-22-2018 at 01:12 PM. Reason: Stupid phone auto correct

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •